PHP Classes
elePHPant
Icontem

File: composer.json

Recommend this page to a friend!
Stumble It! Stumble It! Bookmark in del.icio.us Bookmark in del.icio.us
  Classes of Italo Lelis de Vietro  >  Collections PHP Library  >  composer.json  >  Download  
File: composer.json
Role: Auxiliary data
Content type: text/plain
Description: Auxiliary data
Class: Collections PHP Library
Manipulate collections of values
Author: By
Last change: Adding many new datastructures implementations
Added many features following the RX initiative
Updating phpunit
Fixing new repo name
Adding *flatMap* implementation
Adding reduce method as part of RX iniciative
Fixed composer dependencies
Updating to PSR-4 strcucture
Fixing some issues
Changing interfaces names to psr
Update composer.json
Update composer.json
Stable version
Merge branch 'master' of github.com:LellysInformatica/collections
Update composer.json
Removing target_dir
New structure to the component.
New RecursiveDictirionary class.
Updated tryGet method, now accepts a default value to be returned.
Updated tests.
Removing php version from composer
Merge branch 'master' of github.com:LellysInformatica/collections
Date: 27 days ago
Size: 850 bytes
 

Contents

Class file image Download
{
  "name": "easyframework/collections",
  "description": "Easy Framework Collection Component",
  "type": "library",
  "license": "MIT",
  "keywords": [
    "framework",
    "easy",
    "generics",
    "collection"
  ],
  "homepage": "https://github.com/LellysInformatica/collections",
  "authors": [
    {
      "name": "Ítalo Lelis de Vietro",
      "email": "italolelis@lellysinformatica.com"
    }
  ],
  "require": {
    "easyframework/generics": "~2.0",
    "symfony/property-access": "~2.6"
  },
  "require-dev": {
    "php": ">=5.4.0",
    "phpunit/phpunit": "~4.5",
    "symfony/var-dumper": "~2.6."
  },
  "autoload": {
    "psr-4": {
      "Collections\\": "src/"
    }
  },
  "autoload-dev": {
    "psr-4": {
      "Tests\\Collections\\": "tests/"
    }
  },
  "extra": {
    "branch-alias": {
      "dev-master": "4.0-dev"
    }
  }
}