Login   Register  
PHP Classes
elePHPant
Icontem

Specify requirements

Recommend this page to a friend!
Stumble It! Stumble It! Bookmark in del.icio.us Bookmark in del.icio.us

      PHP Classes blog  >  Encouraging the Autho...  >  All threads  >  Specify requirements  >  (Un) Subscribe thread alerts  
Subject:Specify requirements
Summary:A lot of error reports are because requirements aren't met
Messages:2
Author:Arturs Sosins
Date:2011-12-27 10:19:17
Update:2012-01-22 02:54:02
 

  1. Specify requirements   Reply   Report abuse  
Picture of Arturs Sosins
Arturs Sosins
2011-12-27 18:42:28
Hello,

I don't know if same thing happens to other authors, but on my behalf, I would like to suggest a feature, an ability to specify requirements for published classes.

Mostly when I get error reports, they are like, I've downloaded your package, tried it and it didn't work, it throws out this error: Error text.

Most of these cases are because, user didn't have a specific module or component installed with his or her PHP instalation.

For example: Curl, libxml, json, gd2, OpenSSL, pdo and even Internet Connection (some packages might run on local hosts, others need remote API, etc).

So if anyone else gets the same, maybe it would be a useful feature.

  2. Re: Specify requirements   Reply   Report abuse  
Picture of Manuel Lemos
Manuel Lemos
2012-01-22 02:54:02 - In reply to message 1 from Arturs Sosins
Well the site already lets authors specify classes the users need to have to use other classes. A message is shown when the user downloads a package. Still some users ignored that message, so I am afraid situations like that will still happen.

Anyway, thank you for the suggestion. Maybe in the future there will be something for that purpose.