Login   Register  
PHP Classes
elePHPant
Icontem

Use html5; forget about flash

Recommend this page to a friend!
Stumble It! Stumble It! Bookmark in del.icio.us Bookmark in del.icio.us

      PHP Classes blog  >  How to Use a Webcam t...  >  All threads  >  Use html5; forget about flash  >  (Un) Subscribe thread alerts  
Subject:Use html5; forget about flash
Summary:jpegcam not supported since 2010
Messages:2
Author:Jeffrey Kurtock
Date:2014-02-27 15:06:11
Update:2014-02-28 04:31:55
 

  1. Use html5; forget about flash   Reply   Report abuse  
Picture of Jeffrey Kurtock
Jeffrey Kurtock
2014-02-27 19:38:07
According to https://code.google.com/p/jpegcam/ , development on the .js file needed by this example ended in 2010.

Why? Probably because html5 made Flash (at least any use of Flash to access the camera) obsolete.

Try http://www.html5rocks.com/en/tutorials/getusermedia/intro/ for a basic introduction. Not all browsers support the camera in exactly the same way, but the polyfill is not too difficult, and the results are far superior to anything with Flash.

  2. Re: Use html5; forget about flash   Reply   Report abuse  
Picture of Manuel Lemos
Manuel Lemos
2014-02-28 04:31:55 - In reply to message 1 from Jeffrey Kurtock
Right, the matter is that not all users are running a browser that supports HTML5 getUserMedia.

For newer browser versions there is this JavaScript object that is based on HTML5 getUserMedia support:

http://www.jsclasses.org/package/323-JavaScript-Embed-webcam ...