Login   Register  
PHP Classes
elePHPant
Icontem

pop.bizmail.yahoo.com

Recommend this page to a friend!
Stumble It! Stumble It! Bookmark in del.icio.us Bookmark in del.icio.us

      POP3 e-mail client  >  All threads  >  pop.bizmail.yahoo.com  >  (Un) Subscribe thread alerts  
Subject:pop.bizmail.yahoo.com
Summary:13 could not connect to the host "pop.bizmail.yahoo.com"
Messages:6
Author:Maureen M
Date:2008-07-27 08:54:46
Update:2008-07-29 17:21:17
 

  1. pop.bizmail.yahoo.com   Reply  
Picture of Maureen M
Maureen M
2008-07-27 08:54:46
ERROR MESSAGE
==============
Connecting to pop.bizmail.yahoo.com ...
13 could not connect to the host "pop.bizmail.yahoo.com": Permission denied

NOTES
=======
(a) I have tried with port 110 and tls=0 (set it in this file as well as pop3.php), with same error.
(b) I am able to download emails to Outlook Express, using "pop.bizmail.yahoo.com" and port 995. This indicates pop server is not the issue here.

Thanks in advance for you help. (code below).

Maureen
####

CODE (test_pop3.php)
====
<?php
require_once ("pop3.php");
/* Uncomment when using SASL authentication mechanisms */
/*
require("sasl.php");
*/
$pop3=new pop3_class;
$pop3->hostname="pop.bizmail.yahoo.com";
$pop3->port=995;
$pop3->tls=1;
$pop3->realm="";
$pop3->workstation="";
$apop=0;
$pop3->authentication_mechanism="USER";
$pop3->debug=1;
$pop3->html_debug=1;
$pop3->join_continuation_header_lines=1;
if(($error=$pop3->Open())=="")
{
echo "<PRE>Connected to the POP3 server &quot;".$pop3->hostname."&quot;.</PRE>\n";


} else print ($error);
?>

  2. Re: pop.bizmail.yahoo.com   Reply  
Picture of Manuel Lemos
Manuel Lemos
2008-07-27 18:49:53 - In reply to message 1 from Maureen M
I think you may be using incorrect authentication credentials or authentication mechanism. According to the Yahoo documentation you should be using the Yahoo user ID as POP3 user, so it does not include any @ character and domain name.

I do not have a bizmail account to test but it could connect to either port 110 or port 995 with TLS (security) option enabled.

At least for non-TLS connections, you probably may not use the regular USER mechanism because passwords are passed as plain text.

In that case you need to set the authentication_mechanism variable to empty string and uncomment the sasl.php include line, so the class can negotiate a more secure authentication mechanism.

  3. Re: pop.bizmail.yahoo.com   Reply  
Picture of Maureen M
Maureen M
2008-07-28 23:00:48 - In reply to message 2 from Manuel Lemos
I tried with $pop3->authentication_mechanism=""; and including sasl.php. Same error: 13 could not connect to the host "pop.bizmail.yahoo.com": Permission denied

My temporary test environment:
Yahoo ID: test_popbizmail@yahoo.com
pwd: pop3class

Biz email box to be accessed is: test_pop3@mansionselect.com

Appreciate if you could give your pop3 class a quick try to see if you are able to access and read the test email in this box.

  4. Re: pop.bizmail.yahoo.com   Reply  
Picture of Manuel Lemos
Manuel Lemos
2008-07-29 02:01:51 - In reply to message 3 from Maureen M
You need to use test_pop3@mansionselect.com as user name. I tried it and it worked.

  5. Re: pop.bizmail.yahoo.com   Reply  
Picture of Maureen M
Maureen M
2008-07-29 08:47:59 - In reply to message 1 from Maureen M
Pl. could you list your tried sample lines, I executed with the following and still getting the permission denied error (I also tried uncommenting sasl.php, tls=1, authentication_mechanism=""....same error).

require_once pop3.php");
// require{"sasl.php");
$pop3=new pop3_class;
$pop3->hostname="pop.bizmail.yahoo.com";
$pop3->port=995;
$pop3->tls=0;
$user="test_pop3@mansionselect.com";
$password="pop3class";
$pop3->realm="";
$pop3->workstation="";
$apop=0;
$pop3->authentication_mechanism="USER";
$pop3->debug=1;
$pop3->html_debug=1;
$pop3->join_continuation_header_lines=1;

if(($error=$pop3->Open())=="")
{
echo "<PRE>Connected to the POP3 server &quot;".$pop3->hostname."&quot;.</PRE>\n";
$error = $pop3->Login($user,$password, $apop);
echo "done";


} else print ($error);

  6. Re: pop.bizmail.yahoo.com   Reply  
Picture of Manuel Lemos
Manuel Lemos
2008-07-29 17:21:17 - In reply to message 5 from Maureen M
If you use port 995, you need to set tls to 1. Otherwise you need to use port 110 .