Login   Register  
PHP Classes
elePHPant
Icontem

PHP 4.x.x

Recommend this page to a friend!
Stumble It! Stumble It! Bookmark in del.icio.us Bookmark in del.icio.us

      Create ZIP File  >  All threads  >  PHP 4.x.x  >  (Un) Subscribe thread alerts  
Subject:PHP 4.x.x
Summary:The class has to be modified in order to work in php 4.x.x
Messages:6
Author:Hugo Rene de Luna Castro
Date:2007-10-01 11:26:20
Update:2009-12-22 18:55:08
 

  1. PHP 4.x.x   Reply   Report abuse  
Picture of Hugo Rene de Luna Castro
Hugo Rene de Luna Castro
2007-10-01 11:26:20
The class works great! Thank you.

One thing though; I noticed that the class has public variables and functions (methods actually), but php 4.x.x doesn't understand those things.

So if you want to make the class work in php 4.x.x, you have to change it a little bit. Just replace all the variables from `public' to `var'; for instance:

`public $compressedData' to `var $compressedData'

Also, the `public' in all the functions has to go away, such as:

`public function getZippedfile()' to `function getZippedfile()'

That should do it.

Thanks.

  2. Re: PHP 4.x.x   Reply   Report abuse  
Picture of Er. Rochak Chauhan
Er. Rochak Chauhan
2007-10-01 12:13:10 - In reply to message 1 from Hugo Rene de Luna Castro
Thanks,

Here you go:

http://rochakchauhan.com/blog/2007/09/12/how-to-make-a-php-5 ...

  3. Re: PHP 4.x.x   Reply   Report abuse  
Picture of drsmith
drsmith
2007-10-11 01:13:13 - In reply to message 2 from Er. Rochak Chauhan
Thank you "Er. Rochak Chauhan" for your good work
but i used this class with local server and worked very excellent But when i used it on my web server this message appeared;

Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /home/urlearn/public_html/sigm/createZip.inc.php on line 11

Please give me the reason as it a very excellent class.

  4. Re: PHP 4.x.x   Reply   Report abuse  
Picture of Er. Rochak Chauhan
Er. Rochak Chauhan
2007-10-11 08:55:34 - In reply to message 3 from drsmith
Hi
First of all thanks for the appreciation.
The message indicated that the PHP version you are using is less than PHP5, and the class is codded specifically for PHP5 and not for PHP4.

To fix:
1) Upgrade your PHP version to 5.

2) Follow these steps to make the class compatible in PHP4.

URL: http://rochakchauhan.com/blog/2007/09/12/how-to-make-a-php-5-class-work-in-php-4/

  5. Re: PHP 4.x.x   Reply   Report abuse  
Picture of drsmith
drsmith
2007-10-11 18:08:03 - In reply to message 4 from Er. Rochak Chauhan
Thank you

  6. Re: PHP 4.x.x   Reply   Report abuse  
Picture of behnish
behnish
2009-12-22 18:55:08 - In reply to message 4 from Er. Rochak Chauhan
Hey

I am getting this error

Fatal error: Maximum execution time of 60 seconds exceeded in \zip\CreateZipFile.inc.php on line 96

thanks