Login   Register  
PHP Classes
elePHPant
Icontem

Server configuration required to make this work?

Recommend this page to a friend!
Stumble It! Stumble It! Bookmark in del.icio.us Bookmark in del.icio.us

      cPanel API  >  All threads  >  Server configuration required to make this work?  >  (Un) Subscribe thread alerts  
Subject:Server configuration required to make this work?
Summary:Basic location to runscripts and config settings.
Messages:3
Author:Jamie Smith
Date:2009-07-18 13:36:33
Update:2009-09-23 18:36:32
 

  1. Server configuration required to make this work?   Reply  
Picture of Jamie Smith
Jamie Smith
2009-07-18 13:36:33
OK the class looked nice and the examples seemed easy enough.
/I entered in my server name, username and password but received not response with 0 values and array errors shown (similar to another thread in this forum)

I then tried SSL on and off and combination of ports 2082 and 2083.
I ran the connection from my local hosted apache server and from the actual cpanel server, and from and account on the panel server.
I tried cpanel.doaminname.com and domainname.com and the IP address as connection options. but no change in the response.

I don't see any errors on the php_error.log files apart from the array access error as it is null. I can't see any connection to the server on the cpanels 'raw log files' though I have a feeling it won't log those not on port 80.

Does anyone have any ideas here for me?

Do I need to enable something in the cPanel side before it will work. how can I get some feedback as to where this is failing - the connection, the username/pass the port or https / http. I have check and tried many combinations of these but still get nothing much to go on.

Please help.

The cpanel account and others I have access to are created through WHM, I'm not overly familiar with how these two co-exist or interact.

cPanel Version 11.24.5-RELEASE
cPanel Build 37127
Theme x3
Apache version 2.2.11 (Unix)
PHP version 5.2.9

  2. Re: Server configuration required to make this work?   Reply  
Picture of Jamie Smith
Jamie Smith
2009-09-01 15:47:27 - In reply to message 1 from Jamie Smith
OK.. well this forum seems dead as I have had no feedback... I still have not been able to get this working however a big stumbling block I discovered would have been the blocking of curl by my hosting provider... if anyone else has any ideas...

  3. Re: Server configuration required to make this work?   Reply  
Picture of tony
tony
2009-09-23 18:36:32 - In reply to message 1 from Jamie Smith
Hi Jamie,

I am having similar problems too in getting this class to work.

I too am using cPanel 11 with the x3 theme.

I believe the script was created for use with the x theme.

But there are few differences between the two.

Have you had any success?

Or have you given up?

Regards

Tony