Login   Register  
PHP Classes
elePHPant
Icontem

Errors setting up FFMPEG on a Media Temple server to run phpvide

Recommend this page to a friend!
Stumble It! Stumble It! Bookmark in del.icio.us Bookmark in del.icio.us

      PHP Video Toolkit  >  All threads  >  Errors setting up FFMPEG on a Media Temple server to run phpvide  >  (Un) Subscribe thread alerts  
Subject:Errors setting up FFMPEG on a Media Temple server to run phpvide
Summary:Errors setting up FFMPEG on a Media Temple server to run phpvide
Messages:1
Author:Joren Rapini
Date:2010-01-31 07:27:44
 

  1. Errors setting up FFMPEG on a Media Temple server to run phpvide   Reply  
Picture of Joren Rapini
Joren Rapini
2010-01-31 07:27:45
Hey everyone, having issues getting this working following the instructions on this website. I have a media temple dedicated server and I'm trying to get phpvideotoolkit to work so that I can convert uploaded videos to FLV. I'm brand new to working with console, so go soft on me. First I tried following media temple's instructions and install ffmpeg through yum package installer. Then I followed the instructions that came with INSTALL.txt for this class.


First off, some of the url's for wget do not work, get 404 errors, so I had to track down the right ones, eventually got them all. Everything seems to go fine until I get to the step of compiling FFMPEG, at ./configure --enable-libmp3lame --enable-libogg --enable-libvorbis --disable-mmx --enable-shared I get this error:

GETTING ERROR
"Unknown option "--enable-libogg".
See ./configure --help for available options."

If i try to run the command without --enable-libogg I get this error:

Unable to create and execute files in /tmp. Set the TMPDIR environment
variable to another directory and make sure that it is not mounted noexec.
Sanity test failed.

Finally at the end after I restart the server and run php -r 'phpinfo();' | grep ffmpeg I get:

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules//usr/local/lib/php/extensions/ no-debug-non-zts-20020429/ffmpeg.so' - /usr/lib/php/modules//usr/local/lib/php/extensions/ no-debug-non-zts-20020429/ffmpeg.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules//usr/local/lib/php/extensions/ no-debug-non-zts-20020429/ffmpeg.so' - /usr/lib/php/modules//usr/local/lib/php/extensions/ no-debug-non-zts-20020429/ffmpeg.so: cannot open shared object file: No such file or directory in Unknown on line 0
PWD => /root/ffmpeg/ffmpeg-php-0.6.0
OLDPWD => /root/ffmpeg
_SERVER["PWD"] => /root/ffmpeg/ffmpeg-php-0.6.0
_SERVER["OLDPWD"] => /root/ffmpeg
_ENV["PWD"] => /root/ffmpeg/ffmpeg-php-0.6.0
_ENV["OLDPWD"] => /root/ffmpeg



No clue what to do at this point. . . if I try to run the first example from PHPvideotoolkit I get the error:
FFMPEG ERROR: Execute error. Output for file "/var/www/vhosts/murphyarchive.net/httpdocs/afroninja.mpg" was not found. Please check server write permissions and/or available codecs compiled with FFmpeg. You can check the encode decode availability by inspecting the output array from PHPVideoToolkit::getFFmpegInfo().


Please help me!