Login   Register  
PHP Classes
elePHPant
Icontem

Something is wrong

Recommend this page to a friend!
Stumble It! Stumble It! Bookmark in del.icio.us Bookmark in del.icio.us

      AJAX Treeview  >  All threads  >  Something is wrong  >  (Un) Subscribe thread alerts  
Subject:Something is wrong
Summary:Didn't view the results
Messages:8
Author:Israel Bravo
Date:2007-11-20 10:00:24
Update:2007-12-20 11:35:16
 

  1. Something is wrong   Reply  
Picture of Israel Bravo
Israel Bravo
2007-11-20 10:00:29
Except of a line (instead of tree) I didn't see any results of the demo.
Here is a message from Javascript console:

write is not defined
http://test.technion.ac.il/ajax_tree/tree.js

The same results are in IE and Firefox.

What may be the problem?

  2. Re: Something is wrong   Reply  
Picture of Neeraj Thakur
Neeraj Thakur
2007-11-20 16:27:05 - In reply to message 1 from Israel Bravo
can you please let me know the php version that you are using. do confirm about availability of JSON extension.

Thanks

  3. Re: Something is wrong   Reply  
Picture of leeoze js
leeoze js
2007-12-07 16:48:18 - In reply to message 2 from Neeraj Thakur
I have the same Prob and my PHP ver. is 4.1

  4. Re: Something is wrong   Reply  
Picture of Neeraj Thakur
Neeraj Thakur
2007-12-07 18:37:55 - In reply to message 3 from leeoze js
thanks for using class.. you need to install php 5 version with JSON support.

  5. Re: Something is wrong   Reply  
Picture of Schordinger Hardy
Schordinger Hardy
2007-12-19 14:32:52 - In reply to message 4 from Neeraj Thakur
I have the same problem, and my PHP version is 5.2.4.
I am sure that the JSON support is enabled.
The JSON version is 1.2.1

  6. Re: Something is wrong   Reply  
Picture of Schordinger Hardy
Schordinger Hardy
2007-12-19 16:20:02 - In reply to message 5 from Schordinger Hardy
I solve my problem now.
I Just change the markup of "services.php".
The original markup is "<?",
after I modify that to "<?php".
The results od demo works~~
thanks for your class!!

  7. Re: Something is wrong   Reply  
Picture of Neeraj Thakur
Neeraj Thakur
2007-12-19 17:25:56 - In reply to message 1 from Israel Bravo
I ve tried the referred URL but not able to execute it. Please let me know the error in detail or refer URL which is working ..

thanks

  8. Re: Something is wrong   Reply  
Picture of Schordinger Hardy
Schordinger Hardy
2007-12-20 11:35:16 - In reply to message 7 from Neeraj Thakur
The service.php use opening <?,
and that will cause two errors.
1.write is not defined, line 1, http://localhost/ajaxtreeview/tree.js
2.invalid XML markup, line 40, http://localhost/ajaxtreeview/tree.js

after use the opening <?php,
this treeview class works fine.