Login   Register  
PHP Classes
elePHPant
Icontem

Problem in fetching files

Recommend this page to a friend!
Stumble It! Stumble It! Bookmark in del.icio.us Bookmark in del.icio.us

      PHP SVN Client  >  All threads  >  Problem in fetching files  >  (Un) Subscribe thread alerts  
Subject:Problem in fetching files
Summary:Problem in fetching files and listing directory structure
Messages:16
Author:Shekhu
Date:2008-06-26 06:38:48
Update:2010-05-04 13:19:40
 
  1 - 10   11 - 16  

  1. Problem in fetching files   Reply   Report abuse  
Picture of Shekhu
Shekhu
2008-06-26 06:38:49
There is a problem in directory listing. All but one files are listed. same for the file content reading. You can read all but one files.
Please provide some necessary solution..

  2. Re: Problem in fetching files   Reply   Report abuse  
Picture of Cesar D. Rodas
Cesar D. Rodas
2008-06-26 15:04:32 - In reply to message 1 from Shekhu
Hello,

Thank you report the bug, it was fixed. Now you can download the new version.

Best regards

  3. Re: Problem in fetching files   Reply   Report abuse  
Picture of Shekhu
Shekhu
2008-06-27 05:40:04 - In reply to message 2 from Cesar D. Rodas
Thanks for the prompt response. At present the directory listing is working fine. I see you have modified the getDirectoryFiles method.
But the file reading content is still not bug free. It is unable to read all the files, at present. For your reference, I am siting a url which is not being read by the client: https://phpmyadmin.svn.sourceforge.net/svnroot/phpmyadmin/trunk/themes/xp_silver/info.inc.php
It is no way link to SSL, since there are several other svn site, part of which is not being read by the client.
I think getFile method also needs to be modified.
Please check in this matter, at the earliest.

  4. Re: Problem in fetching files   Reply   Report abuse  
Picture of Shekhu
Shekhu
2008-06-30 11:59:54 - In reply to message 2 from Cesar D. Rodas
Still waiting for the File Content Reading to get fixed.
Can it be done at the earliest or else I need to look for some other Client.

  5. Re: Problem in fetching files   Reply   Report abuse  
Picture of Cesar D. Rodas
Cesar D. Rodas
2008-06-30 13:24:42 - In reply to message 4 from Shekhu
Hello,

It works perfectly on my test. Here I include my test:

$svn = new phpsvnclient;
$svn->setRepository("https://phpmyadmin.svn.sourceforge.net/svnroot/phpmyadmin/");
echo highlight_string($svn->getFile("/trunk/themes/xp_silver/info.inc.php"));

And here is a live example:

http://cesar.la/test/example.php

  6. Re: Problem in fetching files   Reply   Report abuse  
Picture of Pekka Gaiser
Pekka Gaiser
2008-11-20 11:09:35 - In reply to message 5 from Cesar D. Rodas
I am having problems with the class as well, I use VisualSVN on Windows Server 2003 as the SVN server. I manage to connect to a repository:


require("lib/phpsvnclient.php");

/**
* Creating new phpSVNClient Object.
*/
$svn = new phpsvnclient;
/**
* Repository URL
*/
$svn->setAuth("pekka", "xxx");
$svn->setRepository("https://myservername.de/svn/myrepositoryname/");
$files_now = $svn->getDirectoryFiles("/trunk/");

echo "<pre>";
print_r($files_now);
echo "</pre>";


The output looks like this:

Array
(
[0] => Array
(
[last-mod] => Thu, 13 Nov 2008 23:13:52 GMT
[status] => HTTP/1.1 200 OK
)

[1] => Array
(
[last-mod] => Thu, 13 Nov 2008 23:13:52 GMT
[status] => HTTP/1.1 200 OK
)

[2] => Array
(
[last-mod] => Thu, 13 Nov 2008 23:13:52 GMT
[status] => HTTP/1.1 200 OK
)

There are exactly as many elements in the array as there are files/directories in the repository, but as you can see, they have no path. I have not been able to figure out yet why. Do you have an idea?


  7. Re: Problem in fetching files   Reply   Report abuse  
Picture of Ondra  Rafaj
Ondra Rafaj
2008-12-16 13:18:57 - In reply to message 6 from Pekka Gaiser
I have exactly the same problem ... using usvn

  8. Re: Problem in fetching files   Reply   Report abuse  
Picture of Ondra  Rafaj
Ondra Rafaj
2008-12-16 13:19:43 - In reply to message 6 from Pekka Gaiser
I have exactly the same problem ... try to fetch this: https://fuerte.superhosting.cz/usvn/svn/webgurucms3/ :-(

  9. Re: Problem in fetching files   Reply   Report abuse  
Picture of Ondra  Rafaj
Ondra Rafaj
2008-12-16 13:40:39 - In reply to message 6 from Pekka Gaiser
Now I know where is the problem ... it's in the config file ... if you can't see some part of the result ... go to the line 35, 36 I guess or search in the text for "lp3:baseline-relative-path" and change the lp3 to lp2 ("lp2:baseline-relative-path") not only this row ... will be fine than ...

will be:

define("PHPSVN_NORMAL_REQUEST",'<?xml version="1.0" encoding="utf-8"?><propfind xmlns="DAV:"><prop>
<getlastmodified xmlns="DAV:"/><version-controlled-configuration xmlns="DAV:"/><resourcetype xmlns="DAV:"/><baseline-relative-path xmlns="http://subversion.tigris.org/xmlns/dav/"/><repository-uuid xmlns="http://subversion.tigris.org/xmlns/dav/"/></prop></propfind>');
define("PHPSVN_VERSION_REQUEST",'<?xml version="1.0" encoding="utf-8"?><propfind xmlns="DAV:"><prop><checked-in xmlns="DAV:"/></prop></propfind>');
define("PHPSVN_LOGS_REQUEST",'<?xml version="1.0" encoding="utf-8"?> <S:log-report xmlns:S="svn:"> <S:start-revision>%d</S:start-revision><S:end-revision>%d</S:end-revision><S:path></S:path></S:log-report>');

define("SVN_LAST_MODIFIED","lp1:getlastmodified");
define("SVN_URL","D:href");
define("SVN_RELATIVE_URL","lp2:baseline-relative-path");
define("SVN_FILE_ID","lp2:repository-uuid");
define("SVN_STATUS","D:status");
define("SVN_IN_FILE","D:propstat");
define("SVN_FILE","D:response");

define("SVN_LOGS_BEGINGS","S:log-item");
define("SVN_LOGS_VERSION","D:version-name");
define("SVN_LOGS_AUTHOR","D:creator-displayname");
define("SVN_LOGS_DATE","S:date");
define("SVN_LOGS_COMMENT","D:comment");

define("NOT_FOUND", 2);
define("AUTH_REQUIRED", 3);
define("UNKNOWN_ERROR",4);
define("NO_ERROR",1)

  10. Re: Problem in fetching files   Reply   Report abuse  
Picture of Ondra  Rafaj
Ondra Rafaj
2008-12-16 13:56:25 - In reply to message 9 from Ondra Rafaj
and there is "else $enable = false;" missing on line 338 in main svn class ... :-) ... but thanks anyway ... works nice :-)

 
  1 - 10   11 - 16