Login   Register  
PHP Classes
elePHPant
Icontem

its gives errors on php.

Recommend this page to a friend!
Stumble It! Stumble It! Bookmark in del.icio.us Bookmark in del.icio.us

      PHP INI Config  >  All threads  >  its gives errors on php.  >  (Un) Subscribe thread alerts  
Subject:its gives errors on php.
Summary:Package rating comment
Messages:2
Author:adnan
Date:2013-03-11 14:47:27
Update:2013-03-11 15:23:57
 

adnan rated this package as follows:

Utility: Bad
Consistency: Not sure
Examples: Not sure

  1. its gives errors on php.   Reply  
Picture of adnan
adnan
2013-03-11 14:47:27
its gives errors on php.ini file reading.

its totally wastage of time.

  2. Re: its gives errors on php.   Reply  
Picture of Norbert Kiszka
Norbert Kiszka
2013-03-11 15:23:57 - In reply to message 1 from adnan
Did You configure it properly?

Parser (class Ini_Parser: lib/Ini/Parser.php) is working by default with nested sections. If You want to parse traditional ini file, You must disable it:

by Conf: $conf = new Conf('/etc/php5/cli/php.ini', false);

by Ini_Parser: Ini_Parser::parseFile($ini_file, false);

Second parameter is for enable nesting. It's set to true by default.

Further versions will generate errors when sections aren't closed - like a sgml ([section][/section]).

I think this errors are generated because You try to get unavailable section/variable.