PHP Classes
elePHPant
Icontem

File: composer.json

Recommend this page to a friend!
  Classes of Sergii Pryz  >  NASA Near Earth Orbit API Client  >  composer.json  >  Download  
File: composer.json
Role: Auxiliary data
Content type: text/plain
Description: Auxiliary data
Class: NASA Near Earth Orbit API Client
Get near Earth orbit object data with NASA API
Author: By
Last change: Updated symfony component dependency from '~3.1' to '~2.8 || ~3.1'
Date: 2 years ago
Size: 1,201 bytes
 

 

Contents

Class file image Download
{
  "name": "picamator/neo-ws-client",
  "description": "Client for NASA Open Api: Near Earth Object Web Service",
  "keywords": ["NASA", "JPL", "NeoWs", "hazardous", "asteroid", "earth", "neo", "client"],
  "license": "MIT",
  "authors": [
    {
      "name": "Sergii Pryz",
      "email": "picamator@gmail.com"
    }
  ],
  "support": {
    "issues": "https://github.com/picamator/NeoWsClient/issues"
  },
  "autoload": {
    "psr-4": {
      "Picamator\\NeoWsClient\\": "src/"
    },
    "exclude-from-classmap": [
      "/dev/tests/"
    ]
  },
  "autoload-dev": {
    "psr-4": {
      "Picamator\\NeoWsClient\\Tests\\Unit\\": "dev/tests/unit/src",
      "Picamator\\NeoWsClient\\Tests\\Integration\\": "dev/tests/integration/src"
    }
  },
  "minimum-stability": "stable",
  "require": {
    "php": "~5.6|~7.0",
    "psr/http-message": "~1.0",
    "guzzlehttp/guzzle": "~6.2",
    "symfony/dependency-injection": "~2.8 || ~3.1",
    "symfony/proxy-manager-bridge": "~2.8 || ~3.1",
    "symfony/config": "~2.8 || ~3.1",
    "symfony/yaml": "~2.8 || ~3.1"
  },
  "require-dev": {
    "phpunit/phpunit": "~5.5",
    "phpdocumentor/phpdocumentor": "~2.0",
    "satooshi/php-coveralls": "~1.0"
  }
}