File: composer.json

Recommend this page to a friend!
  Classes of Jorge Castro  >  PHP Document Store One  >  composer.json  >  Download  
File: composer.json
Role: Auxiliary data
Content type: text/plain
Description: Auxiliary data
Class: PHP Document Store One
Store and retrieve key-value pairs in flat files
Author: By
Last change: - 1.11 2019-10-23
* new method setObjectIndex() It sets the default index field for insertObject() and insertOrUpdateObject()
* new method insertObject()
* new method insertOrUpdateObject()
* method select() now could returns a list of indexes of a list of documents
- 1.10 2019-08-30 Some cleaning. Added getSequencePHP() and field nodeId
1.9 2019-02-10 Unlock now tries to unlock. Manuallock field is not used anymore.
1.9 2019-02-10 Unlock now tries to unlock. Manuallock field is not used anymore.
1.8
1.7.3
1.7.2
1.7.2
1.7.1
1.7
1.5
1.5
1.3
1.3
1.2
Date: 11 months ago
Size: 1,168 bytes
 

Contents

Class file image Download
{
    "name": "eftec/documentstoreone",
    "description": "A flat document store for PHP that allows multiples concurrencies.",
    "type": "library",
    "keywords": ["php-library","php","database","file","mapreduce","bigdata"],
    "homepage": "https://github.com/EFTEC/DocumentStoreOne",
    "license": "LGPL-3.0-only",
    "autoload": {
      "psr-4": {
        "eftec\\DocumentStoreOne\\": "lib/"
      }
    },
    "autoload-dev": {
      "psr-4": {
        "eftec\\tests\\": "tests/"
      }
    },  
    "authors": [
        {
            "name": "Jorge Castro Castillo",
            "email": "jcastro@eftec.cl"
        }],
    "extra": {
        "branch-alias": {
          "dev-master": "1.11-dev"
        }
      },
    "suggest": {
        "ext-memcache": "If you want to use memcache for locks",
        "ext-redis": "If you want to use redis for locks. It is not recommended becuase it's slow than folder",
        "ext-apcu": "If you want to use redis for locks. It is not recommended",
        "ext-igbinary": "Some examples could use it"
    },
  "require": {
    "ext-json": "*"
  },
  "require-dev": {
    "phpunit/phpunit": "^5.7 || ^8.0"
  }  
}

For more information send a message to info at phpclasses dot org.