File: README.md

Recommend this page to a friend!
  Classes of Goffy G  >  XOOPS Modules Builder  >  README.md  >  Download  
File: README.md
Role: Documentation
Content type: text/markdown
Description: Documentation
Class: XOOPS Modules Builder
Generate new modules for the XOOPS CMS
Author: By
Last change:
Date: 2 months ago
Size: 3,336 bytes
 

Contents

Class file image Download

Support

Support If you liked the modulebuilder module and thanks to the long process for giving the opportunity to the new module to be created in a moment, consider making a donation to <a href="https://xoops.org/modules/xdonations/" target="_blank" title="Donate to Xoops">Xoops.org</a>

ModuleBuilder version 3.x

Build Status Jenkins coverage Software License Quality Score Gem Latest Version

> Note: This repository contains the code of the modulebuilder module It's under development currently. If you want to build with developers this version of module or create a base modules, you can use the last version of this module at Txmod XOOPS Web Site, and visit the main discussion forum at XOOPS Web Site for more information.

Screenshot: <p align="center"> <img src="https://c6.staticflickr.com/9/8500/29971619205_a397db1039_o.jpg" alt="ModuleBuilder 1.9.1 dashboard"/> </p>

Clear version

Require:

  • XOOPS 2.5.10;
  • XOOPS Admin 1.2;
  • PHP 7.3 or higher;
  • MySQL 5.5; -> Minimum Recommended Using InnoDB Version 5.1 or Later

Adding

- Added: table_solename field in tables - Added: table_install field in tables - Added: table_index field in tables - Added: filed_thead field in fields - Added: filed_tbody field in fields - Added: filed_tfoot field in fields

Info

ModuleBuilder is a module that create other basic modules for XOOPS CMS.

Tested with XOOPS 2.5.11, you can not use it with earlier versions, unless because you don't fit some core files in the background and after some tests.

That is ahead XOOPS versions, and goes to 2.6.0, you should download XOOPS 2.5 and use with this latest version.

Therefore recommended not to use modulebuilder 3.x, with previous versions of XOOPS 2.5.10

System - Tests

PHP = 7.3, 7.4

MySQL = 5.6.20, 5.7.11

Apache = 2.4.10, 2.4.18

XOOPS = 2.5.11

Codeception = 2.0.13

Selenium IDE = 2.9.0

Tutorial:

Tutorial Available Tutorial: coming soon on GitBook. To contribute to the Tutorial, fork it on GitHub

Translation:

Translations on Transifex

Please visit us on https://xoops.org

Current and upcoming "next generation" versions of XOOPS CMS are being crafted on GitHub at: https://github.com/XOOPS


For more information send a message to info at phpclasses dot org.