File: composer.json

Recommend this page to a friend!
  Classes of WsdlToPhp  >  PHP SOAP Package Generator  >  composer.json  >  Download  
File: composer.json
Role: Auxiliary data
Content type: text/plain
Description: Auxiliary data
Class: PHP SOAP Package Generator
Generate package to call SOAP services using WSDL
Author: By
Last change: change symfony components versions in order to match PHP 5.3.3 minimum (the least) requirement
update dependencies's versions
Date: 5 years ago
Size: 1,326 bytes
 

Contents

Class file image Download
{
    "name": "wsdltophp/packagegenerator",
    "description": "Generate hierarchical PHP classes based on a WSDL",
    "type": "library",
    "keywords" : ["soap","wsdl","php","generator"],
    "homepage" : "https://github.com/WsdlToPhp/PackageGenerator",
    "license" : "MIT",
    "authors" : [
        {
            "name": "MikaŽl DELSOL",
            "email": "contact@wsdltophp.com",
            "homepage": "https://www.wsdltophp.com",
            "role": "Owner"
        },
        {
            "name": "Gemorroj",
            "email": "wapinet@mail.ru",
            "role": "Contributor"
        },
        {
            "name": "ceeram",
            "email": "c33ram@gmail.com",
            "role": "Contributor"
        }
    ],
    "support" : {
        "email" : "contact@wsdltophp.com"
    },
    "require": {
        "php" : ">=5.3.3",
        "ext-soap": "*",
        "symfony/console": "~2.8",
        "symfony/yaml": "~2.8",
        "composer/composer": "dev-master",
        "wsdltophp/phpgenerator": "dev-master",
        "wsdltophp/packagebase": "dev-master"
    },
    "require-dev": {
        "fabpot/php-cs-fixer": "~1.11.1"
    },
    "autoload": {
        "psr-4": {
            "WsdlToPhp\\PackageGenerator\\": "src",
            "WsdlToPhp\\PackageGenerator\\Tests\\": "tests"
        }
    }
}

For more information send a message to info at phpclasses dot org.