PHP Classes
elePHPant
Icontem

phpizer.test.php

Recommend this page to a friend!

      phpizer  >  All threads  >  phpizer.test.php  >  (Un) Subscribe thread alerts  
Subject:phpizer.test.php
Summary:phpizer.test.php does not work
Messages:5
Author:Jean Pierre Daviau
Date:2006-11-06 14:25:17
Update:2006-11-11 05:23:40
 

  1. phpizer.test.php   Reply   Report abuse  
Jean Pierre Daviau - 2006-11-06 14:25:17
Hi,

Parse error: parse error, expecting `T_STRING' in c:\documents and settings\jean pierre\bureau\learnphp\phpizer-2006-11-06\phpizer.class.php(238) : eval()'d code on line 29

easyphp 1.8

JPDaviau

  2. Re: phpizer.test.php   Reply   Report abuse  
Asher Wolfstein - 2006-11-06 18:34:19 - In reply to message 1 from Jean Pierre Daviau
After double checking it seems to work on my end. I added a check to make sure we're not 'globalizing' the '$GLOBALS' variable to begin with in the new version.

Please insert this code sample right before the eval statement and return the results here. From there I should be able to ascertain the problem:

$code_ar = explode( "\n", $code );
$linec = 1;
foreach( $code_ar as $line ) {
echo "$linec $line\n";
$linec++;
}

Thanks for the update and notification! We'll get it fixed,
Asher

  3. Re: phpizer.test.php   Reply   Report abuse  
Asher Wolfstein - 2006-11-07 01:09:43 - In reply to message 1 from Jean Pierre Daviau
Ah yes, I understand now.

The PHP3 class is not working at the moment. I need to upgrade it so that it is compatible with Version 2.

Thanks for catching that!

Asher

  4. Re: phpizer.test.php   Reply   Report abuse  
Asher Wolfstein - 2006-11-07 14:50:29 - In reply to message 1 from Jean Pierre Daviau
phpizer.proc.php should work now, it has been updated to be compatible with version 2.0 of the script. Everything works under version 2.0 now.

Enjoy!

And bring all problems here, I'll fix them!
Asher

  5. Re: phpizer.test.php   Reply   Report abuse  
Asher Wolfstein - 2006-11-11 05:23:40 - In reply to message 1 from Jean Pierre Daviau
everything should work now, updated for version 2 on all PHP versions.