PHP Classes
elePHPant
Icontem

runtime error from composer to get phpclasses/php-component-csv

Recommend this page to a friend!

      Top level forums  >  PHP Specialists  >  General  >  runtime error from composer to get...  
Subject:runtime error from composer to get...
Summary:Could not load package phpclasses/php-component-csv
Messages:5
Author:Bilal Yousaf
Date:2017-06-02 09:02:33
Update:2017-06-07 06:04:39
 

  1. runtime error from composer to get...   Reply   Report abuse  
Bilal Yousaf - 2017-06-02 11:24:42
Since today morning i am getting error when i try to update composer.

Could not load package phpclasses/php-component-csv in https://bilalby:79f9
2e3b928d9798d4129eaf4a520b51@www.phpclasses.org: [UnexpectedValueException]
Could not parse version constraint ^1.3.*: Invalid version string "^1.3.*"




C:\xampp\htdocs\contento_configurator>composer update
The "extra.asset-installer-paths" option is deprecated, use the "config.fxp-asse
t.installer-paths" option
Loading composer repositories with package information


[RuntimeException]
Could not load package phpclasses/php-component-csv in https://bilalby:79f9
2e3b928d9798d4129eaf4a520b51@www.phpclasses.org: [UnexpectedValueException]
Could not parse version constraint ^1.3.*: Invalid version string "^1.3.*"



[UnexpectedValueException]
Could not parse version constraint ^1.3.*: Invalid version string "^1.3.*"


update [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--lock]
[--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--no
-suggest] [--with-dependencies] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader]
[-a|--classmap-authoritative] [--apcu-autoloader] [--ignore-platform-reqs] [--p
refer-stable] [--prefer-lowest] [-i|--interactive] [--root-reqs] [--] [<packages
>]...

There are 4 replies in this thread, which are not being displayed.
Browsing this forum thread replies is available only to premium subscribers.


Go to the premium subscriptions page to learn how to become a premium subscriber and have full access to this forum.