Recommendation for a PHP sip client class: I need SIP2 script to run with using the TLS 1.2 protocol

Recommend this page to a friend!
  All requests RSS feed  >  Recommendation for a PHP sip client c...  >  Request new recommendation  >  A request is featured when there is no good recommended package on the site when it is posted. Featured requests  >  No recommendations No recommendations  

Recommendation for a PHP sip client class

A request is featured when there is no good recommended package on the site when it is posted. Edit

Picture of Jay Mali by Jay Mali - 3 months ago (2020-11-13)

I need SIP2 script to run with using the TLS 1.2 protocol

This request is clear and relevant.
This request is not clear or is not relevant.

+1

I am using SSL connection to connecting to the sip2 server but now the server upgraded to require TLS 1.2.

We use this below class (sip2.class.php) to connect SIP2 server and that class uses SSL connect. Any suggestion on how will connect using TLS 1.2 with below script using PHP?

https://github.com/the-codepunker/php-sip2/blob/master/sip2.class.php

  • 2 Clarification requests
  • 2. Picture of adam berger by adam berger - 3 months ago (2020-11-16) Reply

    stream_socket_client ('tlsv1.2: //'.$host.': '. $ port, $ errno, $ errstr, 30, STREAM_CLIENT_CONNECT, $ context)

    • 1. Picture of Manuel Lemos by Manuel Lemos - 3 months ago (2020-11-14) Reply

      It seems you need a more modern class that forces a TLS 1.2 SSL connection.

      Ask clarification

      1 Recommendation

      POP3 e-mail client: Access to e-mail mailboxes using the POP3 protocol

      This recommendation solves the problem.
      This recommendation does not solve the problem.

      0

      Picture of adam berger by adam berger Reputation 50 - 3 months ago (2020-11-16) Comment

      here is the problem of the connection itself, if the license allows, you can add such connections yourself, e.g. stream_socket_client ('tlsv1.2: //'.$host.': '. $ port, $ errno, $ errstr, 30, STREAM_CLIENT_CONNECT, $ context)


      Recommend package
      : 
      : 
      For more information send a message to info at phpclasses dot org.