Updated to PHP 7.4 ???

Recommend this page to a friend!

      PHP Free PDF Library  >  All threads  >  Updated to PHP 7.4 ???  >  (Un) Subscribe thread alerts  
Subject:Updated to PHP 7.4 ???
Summary:Deprecated function used
Messages:3
Author:Gert Massheimer
Date:2021-02-15 15:54:33
 

  1. Updated to PHP 7.4 ???   Reply   Report abuse  
Picture of Gert Massheimer Gert Massheimer - 2021-02-15 15:54:33
In your updated version you still use at line 1149:

<code>
protected function checkMbstringFuncOverload(): void
{
// Check mbstring overloading
if (ini_get('mbstring.func_overload') & 2) {
$this->Error('mbstring overloading must be disabled');
}
}
</code

mbstrings.func_overload is deprecated since PHP 7.2

Please update.

  2. Re: Updated to PHP 7.4 ???   Reply   Report abuse  
Picture of John Conde John Conde - 2021-02-15 18:47:47 - In reply to message 1 from Gert Massheimer
If you look at the code it is throwing an error if that is enabled. It's not actually using it.

  3. Re: Updated to PHP 7.4 ???   Reply   Report abuse  
Picture of Gert Massheimer Gert Massheimer - 2021-02-15 19:33:41 - In reply to message 2 from John Conde
OK, I understand that but maybe with the upcoming compatibility to PHP 8, you wanna reconsider keeping it in the code. PHP 8 throws you an error if you use it.

Anyway, thanks for your quick reply.

 

For more information send a message to info at phpclasses dot org.