PHP Classes
elePHPant
Icontem

Question to László Zsidi

Recommend this page to a friend!

      GIF images into animated GIF with native PHP class  >  All threads  >  Question to László Zsidi  >  (Un) Subscribe thread alerts  
Subject:Question to László Zsidi
Summary:Stated licence is "Freeware", what seems to be no licence at all
Messages:4
Author:Horst Nogajski
Date:2017-10-07 11:07:05
 

 


  1. Question to László Zsidi   Reply   Report abuse  
Horst Nogajski - 2017-10-07 11:07:05
Hi László,

many thanks for your work! We are using both of your classes (gif-encoder & gif-decoder) since three years now, in a so called third-party-module. Now we want to embedd this into the core code base of an open source project (https://processwire.com/) and faces the problem, that there are no open source compatible licences bundled with your libraries. Would you mind to add, for example the MIT or LGPL to them, in addition to "Freeware"?

And don't ask me why "Freeware" isn't appropriate or enough to allow the include, I'm not a lawyer. I'm only got told that this is needed to be on the safe side for open source projects. :-/

All the best,
Horst

  2. Re: Question to László Zsidi   Reply   Report abuse  
László Zsidi - 2017-10-24 12:39:06 - In reply to message 1 from Horst Nogajski
Dear Host!
I have been created encoder and decoder source codes licensed under GNU LGPL on github.

You can find at https://gist.github.com/jacoka

Yours,
László Zsidi

  3. Re: Question to László Zsidi   Reply   Report abuse  
Horst Nogajski - 2017-10-27 11:24:15 - In reply to message 2 from László Zsidi
Dear László,
many thanks! Thats very kind of you and of great help for us. :)

All the best
Horst

  4. Re: Question to László Zsidi   Reply   Report abuse  
Horst Nogajski - 2017-11-14 17:59:39 - In reply to message 3 from Horst Nogajski
Hi László,

sorry for bothering you with this again!

I've been told that LGPL isn't compatible, but one out of

MPL 2.0
https://www.mozilla.org/en-US/MPL/2.0/

MIT
https://opensource.org/licenses/MIT

Apache
https://www.apache.org/licenses/LICENSE-2.0

would be.

Is it possible that you additionally add one of them too, to the Github repo?

Once again sorry for bothering.

All the best
Horst