PHP Classes
elePHPant
Icontem

Error in GhostCrypt Class

Recommend this page to a friend!

      PHP Ghost Crypt  >  All threads  >  Error in GhostCrypt Class  >  (Un) Subscribe thread alerts  
Subject:Error in GhostCrypt Class
Summary:Getting Error
Messages:5
Author:Abdullah Syed
Date:2015-11-18 11:53:22
 

 


  1. Error in GhostCrypt Class   Reply   Report abuse  
Abdullah Syed - 2015-11-18 11:53:22
Parse error: parse error in C:\wamp\www\sec\GhostCrypt.class.php on line 24

i am currently getting this error kindly guide me here i am only using the example files given

  2. Re: Error in GhostCrypt Class   Reply   Report abuse  
Nick Daniels - 2015-11-18 16:17:13 - In reply to message 1 from Abdullah Syed
Hello,

I'm not entirely sure what was causing that, however; I have now implemented new features into the class, so it's like new.

Please attempt to use the new code. Which should be updated now or shortly.

phpclasses.org/package/9381-PHP-Enc ...

Thank you.

  3. Re: Error in GhostCrypt Class   Reply   Report abuse  
Dave Smith - 2015-11-18 16:47:12 - In reply to message 1 from Abdullah Syed
It looks like line 24 was where the output file name was being generated. I suspect you may need a newer PHP version to handle the way the file name is being extracted from the extension.

I would say you need at least PHP 5.4, maybe even 5.5 to run the latest version of this class.

If you try the latest version of this class and still are having problems, post the code from the line which is failing and someone can take a look at it.

Dave

  4. Re: Error in GhostCrypt Class   Reply   Report abuse  
Imran Aziz - 2015-11-20 16:24:35 - In reply to message 1 from Abdullah Syed
Same here i am also getting this error.
qu.edu.sa/en

  5. Re: Error in GhostCrypt Class   Reply   Report abuse  
Nick Daniels - 2015-11-20 16:56:42 - In reply to message 4 from Imran Aziz
Hello,

Have you tried the newer version?

Perhaps you have the older version? Please try the newer one.

Regards,